Making Transparent PNGs for Profile Edits

https://youtu.be/6WJj6iNr6K0 The easiest way I found to make transparent pngs on a variety of different images is by using the pen tool to select your images in photoshop, try to find the highest resolution of the image you want to crop out possible this will make it much easier to define the borders when zooming in (ALT + Mousewheel)    
Once you've made your slection on the bottom right hand side you want to select "Path", right click on "Work Path" -> "Make Selection" usually i add a very light feather .04 or so depending on the image. Hit "OK". Now you have a Section of your artist. Now that you have a selection if you need to crop out places like between legs, args, earrings, etc you can click on the pen tool after and select the area you want to make transparent and go back to work path from the steps above and this time hit "Subtract from selection" you can repeat this process as many times as you need until it's fully transparent.  
Once you have everything selected you can hit the add mask button at the bottom right of your photoshop   
From here you should see a checkerboard background and on your right side photoshop tools also have a option to add a feather if your want to smooth out your edges some. To remove all blank space we want to go to "Image" -> "Trim" and be sure to select Transparent Pixels and hit "OK"    
Now it's time to make your image fit the correct size. Go to "File" - > "New" and use the sizing that is required for the image you want to edit on our site for example I'll be making a 540x400 (Thumbnail) png be sure to select the background contents as transparent before creating. Now you should have two tabs, one with the image we just cropped out and the other with a blank transparent canvas. We want to go back to the image we just cropped and go to Edit -> Transform -> Scale  
Now we need to grab one of the blue squares and scale it down to fit our blank canvas    
Now go to your move tool in the top left and click on your cropped image and hit ctrl + c to copy and switch tabs to your blank canvas and hit ctrl + v to paste it    
Now it's time to export your image so we can upload it to kpopping. Go to File -> Export -> Export As... and be sure to select PNG and check transparency and hit "EXPORT"